[ODE] dGeomMoved hook
Jon Watte (ODE)
hplus-ode at mindcontrol.org
Sun Oct 14 20:20:18 MST 2007
OK, from a code reading point of view, this looks good. And I think it's
a good change, as it will improve performance for scenes that use lots
of disabled bodies. Thanks!
I recommend adding it, although I haven't built it myself.
Daniel K. O. wrote:
> Jon Watte (ODE) escreveu:
>> I don't like the name for dGeomGetBodyNext(), even if it was there
>> before. dBodyGetFirstGeom() and dBodyGetNextGeom() would be good names,
>> I suppose -- except you'd pass a geom to the second function...
> I also prefer dBodyGetNextGeom(), and added it in my third attempt:
> It currently just forwards the work to dGeomGetBodyNext(). It was never
> meant to be a public function anyway; should it be deprecated?
>> I don't like this part, though, as the callback might get called more
>> than once per body -- and you don't get a callback if the body has no
> I didn't consider bodies without geoms; thanks for reminding me. Now I
> moved the code to dxStepBody().
More information about the ODE