[ODE] dGeomMoved hook

Daniel K. O. danielko.listas at gmail.com
Sun Oct 14 16:57:36 MST 2007

Jon Watte (ODE) escreveu:
> I don't like the name for dGeomGetBodyNext(), even if it was there
> before. dBodyGetFirstGeom() and dBodyGetNextGeom() would be good names,
> I suppose -- except you'd pass a geom to the second function...

I also prefer dBodyGetNextGeom(), and added it in my third attempt:

It currently just forwards the work to dGeomGetBodyNext(). It was never
meant to be a public function anyway; should it be deprecated?

> I don't like this part, though, as the callback might get called more
> than once per body -- and you don't get a callback if the body has no
> geom.

I didn't consider bodies without geoms; thanks for reminding me. Now I
moved the code to dxStepBody().

Daniel K. O.
"The only way to succeed is to build success yourself"

More information about the ODE mailing list